back to blog...

29-Oct-2018

After sitting in cold/hot storage for the better part of four years, I finally got around to getting out my original 1541 floppy disk drive and giving it a test drive. Right from the get-go, however, the drive didn't sound very good, nor did it appear to work properly. Oh boy.

Upon start-up, the spinning of the center spindle sounded terrible, making a “wysh, wysh, wysh” sound. I put a test floppy into the drive and tried to read the directory, which worked, but loading a program resulted in disk errors. Along with disk errors, there was a high pitched sound which seemed to coincide with the movement of the read/write head assembly. I thought that the less than perfect storage conditions had done in my floppy drive. But, I decided to proceed with trying to fix what I could to see if I could get my old drive working once again.

1541 Floppy Disk Drive

I took the top cover off and inspected the circuit board inside. This particular 1541 is the original long board model with ALPS mechanics. Everything looked fine and I was surprised at how clean the inside of the drive was. I then removed the circuit board and focused my attention on the head assembly and center spindle. It all looked okay to me, but the movement of the head assembly didn't feel very smooth. However, the stepper motor and drive belt looked good.

I took some light oil (the same oil I use to lubricate my air compressor tools) and applied a small amount to the two head assembly rails, as well as forced a few drops under the center spindle. And, before securing the circuit board back into place and closing up the case, I cleaned off the read/write head with some alcohol.

1541 Internals

I had no idea if this would be enough to get my disk drive running properly again, but I thought I'd give it another try.

When I powered up the drive, I heard the same wyshing sound of the center spindle, but this time it was much quieter. I inserted a disk and tried to read a directory. Again, I heard the high pitched sound I heard earlier, but it only lasted for a few seconds. I tried loading a program off of the disk and this time, it worked!

I followed up by giving the head assembly some exercise by trying to format a new disk. As the oil got distributed by the moving mechanics, all of the odd noises faded away and the drive seemed to be working perfectly, once again.

From what I've read about the differences between each model of the 1541 disk drives, the ALPS mechanics are known to be the noisy-est. However, as it is right now, my old 1541 is even quieter than my 1541-IIs. I guess it's time for me to crack those open and give them a shot of oil, as well.

I'm pleasantly surprised that all I needed to do was apply a bit of lubrication to get my old 1541 working properly again. But, then again, the ALPS mechanics are considered as being pretty reliable. I guess the general opinion is right, in this regard. What a marvel of electronic engineering!

Hopefully this disk drive will now provide me with reliable service for many more years to come.

Repair Tip

I don't know much about doing these kind of repairs. However, I have learned that when dealing with older, brittle plastics, like found on 30+ year old computers, do not over tighten housing screws. When putting older equipment, like a vintage C64 or 1541 disk drives, back together again, only tighten case/housing screws until you feel first signs of resistance. Over tightening can results in cracking the old, brittle plastic of the housing or stripping the screw hole.

Composed on my C128 with ArcheType

Last modified le 2018/11/11 16:49